Polaris General Forum banner
1 - 20 of 20 Posts

·
Registered
2021 Polaris General
Joined
·
116 Posts
Discussion Starter · #1 · (Edited)
Hello All,
I am a novice at wiring and anything electrical. I need help in wiring my wiper motor, windshield washer pump and Rocker Switch. I am wiring to the 3-position busbar (add-on). I have attached a diagram of the motor, pump, switch & busbar connection points. I would like these to be "key-on" devices. Could someone show the correct wiring procedure using my drawing so that I can complete this project? I would really appreciate your help, thanks in Advance! I should also point out that the white wire for the wiper motor is to put it back to the "Park" position.
Handwriting Rectangle Font Parallel Diagram
 

·
Registered
2020XP4
Joined
·
2,218 Posts
The keyed power at the pulse bar is only fused at 10 amps and it's shared. You can't power the wiper/washer system from it, or you will blow fuses. You need to power the wiper through a relay and you trigger that relay with the ignition switched power. This keeps the load on that ignition trigger circuit low.
 

·
Registered
2021 General 4 XP Ride Command
Joined
·
247 Posts
How does your switch work?
All the way down =off
Up one click = wiper on
Up one more click and hold = washer

that is how mine is, but the prongs on the back of my switch are different, and your diagram has me thinking yours is middle =off down would do one function and up would do the other ? I ran my wiper on a relay, but not the washer pump
 

·
Registered
2021 Polaris General
Joined
·
116 Posts
Discussion Starter · #7 ·
My switch is: Up ((On when held)
Middle Off
Down Wiper On

BACAUTOPARTS Blue Led Windshield Washer Wiper Momentary Rocker Switch 7Pin Mom (ON)-Off-ON DPDT Washer Jet Toggle Switch for Automotive UTV RZR Truck Camper RV Tractor 12V 24V
Camera accessory Font Gadget Technology Electronic device
Office supplies Font Cosmetics Writing implement Automotive lighting


What size relay do I need and how is it wired into the circuit? Thanks for the replies!
 

·
Registered
2021 Polaris General
Joined
·
116 Posts
Discussion Starter · #8 ·
Just as an update, I have my wiper/washer install completed and wired it per the drawing above (with a relay). Everything works fine with (1) exception: At some point, usually after the General has been running for a while, the wiper continues to run and will not shut off unless I turn off the ignition. Once I turn the key off, the wiper returns to the home position as it should. What could I have wrong? Thanks for all the help!
 

·
Registered
Joined
·
430 Posts
Just as an update, I have my wiper/washer install completed and wired it per the drawing above (with a relay). Everything works fine with (1) exception: At some point, usually after the General has been running for a while, the wiper continues to run and will not shut off unless I turn off the ignition. Once I turn the key off, the wiper returns to the home position as it should. What could I have wrong? Thanks for all the help!
I have experienced this same issue. I blamed it on the switch and replaced it. I have not used it much since I replaced it so I don't know if the problem is actually solved or if that was even the issue.

I think all of the switches on Amazon are made in the same Chinese sweatshop. If I have to replace it again I will either switch to an Auxbeam setup or use a switch from Ottratw

Sent from my SM-N976U using Tapatalk
 

·
Registered
2022 general XP on the way
Joined
·
1,214 Posts
Mine started doing this again yesterday. For now I'm just going to eliminate the park power circuit.

Sent from my SM-N976U using Tapatalk
Did you use another Amazon switch for the second time?

I have issues with my wiper running continuously after long periods too. I have a cheap ebay switch, going to switch to a better quality switch. It's the only thing I can think of...

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
430 Posts
Did you use another Amazon switch for the second time?

I have issues with my wiper running continuously after long periods too. I have a cheap ebay switch, going to switch to a better quality switch. It's the only thing I can think of...

Sent from my SM-G998U using Tapatalk
Yep same Amazon cheap switch. I don't actually think the switch is the problem. I can't think how power would bleed through the switch and keep the wiper running.

I think something inside the Ford motor is causing power to bleed from the constant (park) source to the on source.

All I can do is unhook the constant and see if it still does it.

Sent from my SM-N976U using Tapatalk
 

·
Registered
2020XP4
Joined
·
2,218 Posts
Yep same Amazon cheap switch. I don't actually think the switch is the problem. I can't think how power would bleed through the switch and keep the wiper running.

I think something inside the Ford motor is causing power to bleed from the constant (park) source to the on source.

All I can do is unhook the constant and see if it still does it.

Sent from my SM-N976U using Tapatalk
Does the switch light up?
 

·
Registered
2021 Polaris General
Joined
·
116 Posts
Discussion Starter · #18 ·
Did you use another Amazon switch for the second time?

I have issues with my wiper running continuously after long periods too. I have a cheap ebay switch, going to switch to a better quality switch. It's the only thing I can think of...

Sent from my SM-G998U using Tapatalk
Do you think it could be the relay?
 

·
Registered
2020XP4
Joined
·
2,218 Posts
Yes it lights up, and everything seems to work fine until the engine warms up and it has been running for a while, then it stays on. I am beginning to think replacing the
Relay might be the simplest "try".
Try the relay first. The switch being lit could possibly allow power to pass through if something is going on with the internal light circuit. That would be the next thing to replace.
 
1 - 20 of 20 Posts
Top