Polaris General Forum banner
2521 - 2536 of 2536 Posts

·
Registered
2021 General 1000 XP 4 Ride Command
Joined
·
201 Posts
Why would you return the kit? It works flawlessly….if there is an issue, I’m sure they would take care of it.
Once we pulled the unit a part, it already has the same kit installed. We just bought the unit and the previous owner said it did not have a kit in it.... apparently he didn't know. It's all going to work out, my brother n law just bought a 2014 Maverick and is going to buy the kit off my son.
 

·
Registered
Joined
·
399 Posts
Performed the 25hr break in service on the G today. 24.4hours on the clock.

Pretty straightforward work. Got the expected paste/sludge from the magnets but no big pieces of metal.









I was surprised to see that the final drive fluid was mostly clear going in because the stuff coming out of the front diff looked gray/silver as it came out and in the pan.



I also pulled the clutches apart and installed the HW rollers, white washer and HW belt. The OE belt is now my broken in spare under the hood.

I made sure to use only the tools I carry with me on the trail for the belt work. That way I could be confident if I had to do it.

In all, I think I spent about 4.5 hours doing everything.


Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
72 Posts
Yes. Rode 90 miles there yesterday. The paddle tires I put on were too aggressive for the General, so I’ll either sell them or cut them down for next time. The extra torque from the tuning did make a nice difference. I was also very surprised that there wasn’t must belt dust in the clutch housing after how hard I beat on it. The Dalton clutch kit works very well.
SS360's would probably be a fit. I have a set of 32" that I'm probably going to put on the General, I just need some wheels.
 

·
Registered
Joined
·
5,486 Posts
Nice Country!
 
2521 - 2536 of 2536 Posts
Top