Polaris General Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
Called atvtracks.net and ordered the conversion kit to swap from commander to general. He said the sprockets on the general are one tooth off from front to back! I needed new sprockets anyhow and mount kit to make them work. If you buy mounting kit its like 450 bucks plus sprockets and other stuff ! If you buy separate its 1500, but they offer a whole kit for 749! I wonder if anyone else heard about the different sprockets for front and back?
 

·
Registered
Joined
·
808 Posts
It has to do with the awd system. If I recall correctly the "close ratio awd" of the General needs to have the front pulling (turning slightly faster than the rear). The old system needed the rear to turn faster than the front so the machine thinks the rear is losing traction and engages the front diff.

I'm going off foggy memory here though so....
 

·
Super Moderator
Joined
·
4,175 Posts
The sprocket being different is because the front and rear tracks are different lengths. The rear being longer (bigger around if it was a tire) then the front so the front would be (smaller around if it was a tire) just like the mud dragsters I have built in the past. Therefore the front has to run just a little slower then the rear so they cover the same distance and not fighting one another! Hope that is easy to understand
 
  • Like
Reactions: Trapper

·
Registered
Joined
·
808 Posts
If that was the case all kits would be the same (rear small, front large) but they're not. The setup for my Rzr 900 XP is different than the setup for my General even though the same set of tracks is used on both. The drive sprockets need to be swapped to match the AWD system.
 

·
Super Moderator
Joined
·
4,175 Posts
from what I understand on the General. The AWD uses the same final drive front and back 1 to 1 if you will. And for that reason is why I think the sprockets are dif. front to back as I stated! so the tracks cover the same distance front and back. other units like you state may not use the same final drive. May not be there reason but that's My take on why!
 
1 - 6 of 6 Posts
Top