Polaris General Forum banner

1 - 20 of 43 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hi all, started to do the 25 hrs oil changes starting with the front diff. Loosen the drain plug all good went to loosen the fill plug won't budge!! Well you know what happen next ! stripped that baby out, any ideas on how to extract this would be welcome.

Thanks
 

·
Registered
Joined
·
152 Posts
Haven't had my head under there yet but if there is room you can always try a hammer and a small center punch and try to drive the plug in a circle to loosen it or you can always weld a nut on it and use a wrench but I would save that for a last resort.
 

·
Registered
Joined
·
95 Posts
Hi all, started to do the 25 hrs oil changes starting with the front diff. Loosen the drain plug all good went to loosen the fill plug won't budge!! Well you know what happen next ! stripped that baby out, any ideas on how to extract this would be welcome.



Thanks


Just go get an extraction tool. Has reversed grooves that grab hard. It's worth the 20 bucks I promise you. It'll work better than anything else you try. Why they make em like they do.


Sent from my iPhone using Tapatalk
 

·
Senior Member
Joined
·
1,563 Posts
Order a couple extra. It's poopoo any way so if you have a hard time a little heat or the welded nut like bullet suggested will get her out.
 

·
Registered
Joined
·
161 Posts
If the head of the allen bolt is exposed and accessible to a hammer and cold chisel you can tap a notch in it,and then angle the chisel the appropriate direction and whack it with a hammer.
I'm assuming you stripped out the box end of the bolt?
 

·
Registered
Joined
·
112 Posts
General Todd, mine is at the dealer also. I'm not quite sold on this thing yet, I have had nothing but problems right from the start. Its got 3.5 hours on it and its been at the dealer this whole week and still have not heard a word about it. Not a happy camper!
 

·
Registered
Joined
·
95 Posts
General Todd, mine is at the dealer also. I'm not quite sold on this thing yet, I have had nothing but problems right from the start. Its got 3.5 hours on it and its been at the dealer this whole week and still have not heard a word about it. Not a happy camper!


Should have waited a year to buy. As long as they have had the RZR and still have issues. We are gonna have problems also. That's why Polaris loves the warranty because they can track what broken parts/issues are trends and relate them back to the R&D or QC. Mine has been back 3 times in less than 3 months. None of which anything actually came of it. Same as you, a week would go by and no word until I would call and ask. Only advice I can give ya is buy the extended warranty or sell it lol


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
112 Posts
Chall, I understand the point of the first year out and all, but come on they need to do a little Quality Control on them before they go out the door. I have biult cars for 25 years and trust me, I know all about quality control, if we send something out our doors like Polaris has been, we would be out of business. This isn't my first rodeo with Polaris, I bought a snowmobile a few years back and had the same thing go on with that, the first weekend I was able to take it up north to ride it I went thru 12 spark plugs and they said there was nothing wrong with it.
 

·
Registered
Joined
·
161 Posts
General Todd, mine is at the dealer also. I'm not quite sold on this thing yet, I have had nothing but problems right from the start. Its got 3.5 hours on it and its been at the dealer this whole week and still have not heard a word about it. Not a happy camper!
They're making me reconsider paying cash.
Although I dont have a problem with letting em work out the bugs I do have a problem with constant bugs.
We'll see I guess.
 

·
Registered
Joined
·
161 Posts
General Todd, mine is at the dealer also. I'm not quite sold on this thing yet, I have had nothing but problems right from the start. Its got 3.5 hours on it and its been at the dealer this whole week and still have not heard a word about it. Not a happy camper!
Mine came off the trailer without a working speedo.
I did however get to go around the block a few times..........
I'll give them the chance to make things right. I've been through the same problems with new dirt bikes and street bikes for that matter.
 

·
Registered
Joined
·
95 Posts
Chall, I understand the point of the first year out and all, but come on they need to do a little Quality Control on them before they go out the door. I have biult cars for 25 years and trust me, I know all about quality control, if we send something out our doors like Polaris has been, we would be out of business. This isn't my first rodeo with Polaris, I bought a snowmobile a few years back and had the same thing go on with that, the first weekend I was able to take it up north to ride it I went thru 12 spark plugs and they said there was nothing wrong with it.


Completely agree with you on QC hands down man. I realize it's more or less an off road golf cart with too much hp but I've seen better welds on the trailer I built in AG mechanics shop class in high school than what's on my roll cage. And I can also tell they were in a hurry to paint the frame as I've had paint flake off nearly every weld where it was still hot when they painted it. Not to mention when I got mine it had a dent in the roll cage roof support frame on the passenger rear. No paint damage or abrasion of any kind!!!! Clearly it happened before the part was painted. But due to the dealership taking "legal" ownership once they sign off on them after assembly out of the crate and after they have done the (checklist), Polaris would not cover it. Fortunately my dealer grew a manly pair and took care of the issue. Reckon he 40k I've spent with them between my Victory bagger and now the general they were persuaded. Which is good because I would have gone ape **** if they had not and given them the general back. Only I would have drove through the glass store front and parked it in between and/or possibly on one or more Indian chieftains. Cause then I know I would have their attention


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
112 Posts
General Todd, mine I got it home and as soon as I get it up to about 35 or 40 it cuts right out, then it will take off again but as soon as ya get up to that 35 or 40 it does the same thing. I was thinking at first that it was something they program into the break in process, but the dealer said no, so they have it to plug it in and see what the code is that it is throwing. So as soon as I find anything out I will post on here and let you all know what was going on!
 

·
Registered
Joined
·
161 Posts
General Todd, mine I got it home and as soon as I get it up to about 35 or 40 it cuts right out, then it will take off again but as soon as ya get up to that 35 or 40 it does the same thing. I was thinking at first that it was something they program into the break in process, but the dealer said no, so they have it to plug it in and see what the code is that it is throwing. So as soon as I find anything out I will post on here and let you all know what was going on!
I have found that places like this are invaluable when discussing problems with the stealer about your ride.
When you can quote and back up info off the internet they become much more cooperative.
 
1 - 20 of 43 Posts
Top