Polaris General Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
I'm considering purchasing this device since I hate not having a parking brake. How common is the broken bolt issue when this has been used long term? Thanks!
 

·
Registered
Joined
·
2,374 Posts
No trouble or problems at all and use it almost daily!
 

·
Registered
Joined
·
285 Posts
Like Johnny 7 said, don't over tighten. Especially the small bolt on the throttle assembly. Unfortunately, I found out the hard way. Worth having, just use a light touch when tightening.
 

·
Registered
Joined
·
684 Posts
I set it every time I stop. No issues
 

·
Registered
Joined
·
122 Posts
I now use it all the time especially when Trailering the General.
 

·
Registered
Joined
·
77 Posts
I have used mine for almost 7,000 miles, never a problem. I think that the service manual (not the owner’s manual) specifies the torque on the two fasteners (sitting on the porch drinking beer, not interested in going inside to check the service manual!)
 

·
Registered
Joined
·
6 Posts
I found a place that put a parking break on my General but i am still thinking of getting a spring thingy so I can pad lock the brakes when i have it on the trailer
 

·
Registered
Joined
·
2,877 Posts
Dale, what sort of Parking Brake was put on your General? Pics are always nice!!

Have a very early SBT...wanted orange...nope...red! But works just great!! and I set it every time I get out of the General!!

Pirate
 

·
Registered
Joined
·
15 Posts
Great add on! Easy install an performs as expected. I haven’t had any broken bolt issues. Remember that it holds hydraulic pressure on the brake system. I use mine on the trail and on the trailer. I don’t use it when parked in the garage.
 
1 - 11 of 11 Posts
Top