Polaris General Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
227 Posts
My first and I hope only issue is the drivers side rear tire got a pimple and started leaking. 145 miles and tire issue. Hope these stock tires don''t give me any more issues!
 

·
Super Moderator
Joined
·
4,175 Posts
My first and I hope only issue is the drivers side rear tire got a pimple and started leaking. 145 miles and tire issue. Hope these stock tires don''t give me any more issues!
that sounds like a defective tire not a Polaris issue. lets hope they fix it sure they will let us know! :grin2:
 
  • Like
Reactions: Alaskan47 and 2722

·
Registered
Joined
·
831 Posts
The winch switch might be a bad connector on the back of the switch. Mine did that too and I ripped the switch panel off and shoved the connector back on to get the winch to work. I was stuck in the snow in the middle of a large group with a new machine...not happy at that moment.
 

·
Registered
Joined
·
170 Posts
My first and I hope only issue is the drivers side rear tire got a pimple and started leaking. 145 miles and tire issue. Hope these stock tires don''t give me any more issues!
Rear tire on mine leaks as well. Put the soap suds to it and can't find a leak anywhere. Loses a couple psi per day.

Sent from my SM-G930W8 using Tapatalk
 

·
Registered
Joined
·
408 Posts
Rear tire on mine leaks as well. Put the soap suds to it and can't find a leak anywhere. Loses a couple psi per day.

Sent from my SM-G930W8 using Tapatalk
I had this happen once. It was the valve that was loose. Was not screwed in all the way. Check that if you have not.
 

·
Registered
Joined
·
170 Posts
Checked the valve and it is tight,really aggravating having to put air in every time i go for a ride.
 

·
Registered
Joined
·
170 Posts
Yesterday i slacked the pressures up to 9 in the rear and 8 in the front.Much better ride and i checked the pressure today and it still had 9 psi. Go Figure lol.
 

·
Registered
Joined
·
227 Posts
that sounds like a defective tire not a Polaris issue. lets hope they fix it sure they will let us know! :grin2:
Well they covered the tire. They didn't want to but the mechanic said he would send them another 100 pictures if they wanted and they told him just forget it we will cover it. They also did my 1st oil and filter change and first inspection. Some how a rear LED flood and a dome light appeared on it.......I think they like it when I come to town. Bahahahaha:wink2:
 
1 - 10 of 10 Posts
Top