Polaris General Forum banner
1 - 13 of 13 Posts

·
Premium Member
2016 Polaris General Deluxe, 10% OEM
Joined
·
4,655 Posts
Discussion Starter · #1 ·
Twice now I have parked the General for a few minutes, get in, started it up...and the clock is flashing 12:00

Anyone else having this problem?

Pirate:mad:
 

·
Registered
Joined
·
14 Posts
Mines been doing this for awhile and also watch your fuel gauge it will more than likely
start reading incorrectly.
dealer got ahold of Polaris and they told dealer to re flash the computer they have a fix for this
after they re flashed mine the clock would not stay reset it would keep flashing 12.00
bull S***
after still complaining about this (gauge showed 1/2 tank one time when I filled it up it took 8.25 gallon)
they told me bring it back and Polaris hooked in to mine threw the dealers computer today
and got a call awhile ago and they said my cluster is bad and they will be replacing it.
I've been telling dealer about some of the post on this site that other riders have had this
trouble and after they got cluster replaced and trouble was fixed. but after 2 weeks and Polaris
going threw all there BS hope mine is taken care of.
 

·
Registered
Joined
·
1,314 Posts
Every time I tell the dealer that other people on the forum have the same answer the dealer says the Internet forum is full of jokers to put it nicely. I have a friend who is a certified bike mechanic he looks at my bike if there is a problem then I make the 3 hour round trip and tell the dealer to fix it here is my mechanics phone # if you have questions so far they have fixed everything under warranty. If they will not cover under warranty I take back to my friend and he is about 1/2 the price.
 

·
Premium Member
2016 Polaris General Deluxe, 10% OEM
Joined
·
4,655 Posts
Discussion Starter · #6 ·
Well, reading all the responses...I'll keep and eye on mine and if it happens again...I'll use my warranty and take it back to the dealer...120 miles away.

So far, working fine...again.

I guess something for those looking to purchase...ask the dealer and his service manager about the forum, do they look at it? Use it for reference in problem solving? No? Well...maybe another dealer. That's what I did in purchasing the General. Nearly 100 miles further from the house...but people I talked to and have some respect for.

Sad ain't it?

Pirate
 

·
Premium Member
2016 Polaris General Deluxe, 10% OEM
Joined
·
4,655 Posts
Discussion Starter · #8 ·
Mine still does it every now and then, but I've pretty well memorized the instructions for resetting it....so I just do it.

If I hear of a ECU reflash that the Dealer should do...I'll swing by and get mine done. Til then...not that hard and not that much of a PITA.

Pirate
 

·
Super Moderator
Joined
·
4,195 Posts
I saw this post and thought! WOW I don't think I have looked at my clock. Ever. will have to make a point and look for it. :grin2:
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top