Polaris General Forum banner
61 - 80 of 126 Posts

·
Registered
2018 Polaris General 1000 Ride Comand
Joined
·
307 Posts
Just ordered a Inferno for $359.10 shipped to my door from FueledUTV.

EDIT: So do some of the early kits come with dash vents as well?
 

·
Registered
Joined
·
806 Posts
Discussion Starter · #62 ·
The kit should come (for G2) with 2 defrost vents and 2 round vents that are designed to blow down into the foot well areas you can purchase the extra vents that come with the 4 seat kit and add into the dash panel. This may be what you are thinking of….
 

·
Registered
Joined
·
17 Posts
Ok this is still work in progress, still no heat one thing I want to clarify is which hose goes to which port, instructions say front lower radiator y fitting hose up to top heater core port and oil cooler spliced hose to lower port, I watched an install video showing just the opposite and yesterday I called inferno to clarify and the tech told me that the spliced oil cooler hose goes to the top and the lower radiator spliced hose goes to the bottom port. So now I'm confused, how did you guys install it ?
 

·
Registered
2018 Polaris General 1000 Ride Comand
Joined
·
307 Posts
Would it even matter which port you connected the hoses to on the heater core. It is basically water in water out either way. Unless gravity plays a part in it.
 

·
Registered
2018 Polaris General 1000 Ride Comand
Joined
·
307 Posts
So something don't sound right about the hose is cool past the rear Y. Would it be a big pain to remove that Y and look to see if maybe the weld has blocked the inside of it. Or is it a cast piece with no weld?
 

·
Registered
Joined
·
177 Posts
The kit should come (for G2) with 2 defrost vents and 2 round vents that are designed to blow down into the foot well areas you can purchase the extra vents that come with the 4 seat kit and add into the dash panel. This may be what you are thinking of….
I can't say that I have seen a four seat kit. Got a SKU? I see the SKU for stage 4 audio and without.
 

·
Registered
2018 Polaris General 1000 Ride Comand
Joined
·
307 Posts
Well its obvious that the hose from the oil cooler is nothing but air since it it cool. I would almost be inclined to take the hose loose at the heater core, stick a bucket under it and start the motor to see it it has flow.
 

·
Registered
2021 General 4 XP Ride Command
Joined
·
149 Posts
Ok this is still work in progress, still no heat one thing I want to clarify is which hose goes to which port, instructions say front lower radiator y fitting hose up to top heater core port and oil cooler spliced hose to lower port, I watched an install video showing just the opposite and yesterday I called inferno to clarify and the tech told me that the spliced oil cooler hose goes to the top and the lower radiator spliced hose goes to the bottom port. So now I'm confused, how did you guys install it ?
My instructions said the same as yours, return line to the top of the heater core, inlet line goes to the bottom, interesting that they said the opposite on the phone. I installed mine as the instructions said. Starting to wonder if you don't have a faulty/plugged heater core, if you get coolant coming through the oil cooler line after you remove it , may be worth it to try and push some water/coolant through the heater core itself?
 

·
Registered
Joined
·
17 Posts
Can anyone chime in if it should work either way you hook up the hoses, spliced oil cooler to top or bottom, spliced lower radiator hose to top or bottom heater core ports?
 

·
Registered
2020XP4
Joined
·
1,317 Posts
Can anyone chime in if it should work either way you hook up the hoses, spliced oil cooler to top or bottom, spliced lower radiator hose to top or bottom heater core ports?

The instructions can be downloaded from that webpage.
 

·
Registered
Joined
·
17 Posts
Buelligan666/ You probably didn't notice my previous posts, I read the instructions and installed per, but was told from an Inferno tech over the phone to do the opposite of the instructions on the hose hookup to the heater core ports and was looking for some clarity on here, I've heard also that it doesn't matter which hose goes top or bottom but I've been dealing with no heat for days now and I'm looking for the correct install direction, also concerned why service tech says opposite of the instructions?
 

·
Registered
Joined
·
4,350 Posts
I would check your heater core like I mentioned before.
Something isn't right.
 

·
Registered
2018 Polaris General 1000 Ride Comand
Joined
·
307 Posts
I am with Johnny. Something is blocking the hose from the oil cooler thru the core and back to the front hose. And the core is more likely than the new hoses.
 

·
Registered
2020XP4
Joined
·
1,317 Posts
Buelligan666/ You probably didn't notice my previous posts, I read the instructions and installed per, but was told from an Inferno tech over the phone to do the opposite of the instructions on the hose hookup to the heater core ports and was looking for some clarity on here, I've heard also that it doesn't matter which hose goes top or bottom but I've been dealing with no heat for days now and I'm looking for the correct install direction, also concerned why service tech says opposite of the instructions?
In my opinion, the published and posted directions from the manufacturer should be the correct way. If you spoke to a "tech", that could have been anyone in the company willing to answer the phone. It could even be an engineer, and they're usually ALWAYS wrong. Is there any indicator on the heater core for inlet or outlet? An arrow showing flow direction? I know you said you watched several YouTube videos. YouTube is helpful, but you have to wade through all the people who are just trying to be "YouTube famous". In my opinion, if the hose isn't hot at the tee where it should be, you have something else going on. Remember that these machines have a cooling system that is very difficult to bleed the air from. One member blew his motor up because he didn't properly bleed the system after a thermostat replacement.
 

·
Registered
Joined
·
4,350 Posts
Weren't there a few people having problems last year and they had their Y the wrong way or something?
I think TaterTots had some problems with hers also.
 

·
Registered
Super Graphite 2021 XP 1000 Deluxe with RC
Joined
·
148 Posts
Ok this is still work in progress, still no heat one thing I want to clarify is which hose goes to which port, instructions say front lower radiator y fitting hose up to top heater core port and oil cooler spliced hose to lower port, I watched an install video showing just the opposite and yesterday I called inferno to clarify and the tech told me that the spliced oil cooler hose goes to the top and the lower radiator spliced hose goes to the bottom port. So now I'm confused, how did you guys install it ?
I have both instruction sheets in front of me (the heater for the standard General and the heater for the General w/ the RF stage 4 audio) and they both say to connect the return hose (from the Y) to the upper fitting and the inlet hose to the lower fitting. I was wondering if there were two conflicting sets of instructions out there.
 
61 - 80 of 126 Posts
Top