Polaris General Forum banner
21 - 40 of 41 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #21 ·
Sounds like some engineer decided to save Polaris a few cents on every machine.
Gents, I am at a loss and looking for help. I want to install back up / reverse lights on my 2021 General 4 1000 Deluxe.

I am no electrician, but successfully installed light bars, horn, etc., without any issues. I even have a wiring harness set to go if and when I can find the dang things.
I’ve looked at several threads here and studied a lot of pictures. I’ve carefully cut some of the wire wrapping in locations they may have been, with no luck.
Attached is a picture of where I am so far.
Any hints, recommendations, whatever will be most appreciated! View attachment 68774
Well, I finished my rear lights. While they are not connected to reverse as I would like, they provide light for seeing in the bed as well as providing plenty o’ light for backing up.
I owe many thanks to several folks here fire recommendations on hiding the wiring through the cage and the use of grommets, how to run the wires by taking out cup holders and storage boxes, the use of fish tape for pulling wires, to the choice of lights. As you can see in the pic, I think these lights look like they were made for the General.

The worthless Lab did not contribute any meaningful help.

Many thanks, gentlemen!
 

Attachments

·
Registered
Joined
·
245 Posts
Looks great Bill! Could you post a link to the lights you used? I am wanting to do this as well.
 

·
Registered
2021 general xp custom
Joined
·
7 Posts
Gents, I am at a loss and looking for help. I want to install back up / reverse lights on my 2021 General 4 1000 Deluxe.

I am no electrician, but successfully installed light bars, horn, etc., without any issues. I even have a wiring harness set to go if and when I can find the dang things.
I’ve looked at several threads here and studied a lot of pictures. I’ve carefully cut some of the wire wrapping in locations they may have been, with no luck.
Attached is a picture of where I am so far.
Any hints, recommendations, whatever will be most appreciated! View attachment 68774
68968
 

·
Premium Member
2021 General XP 4
Joined
·
111 Posts
I took the box off and did some more digging today. Those two wires are not in the harness any were from about were the first harnesses split off al the way to the ends. I also don't see a black wire with a white stripe in the harness there. I did find a wire that was smashed inside the wrapping and the coating was open. I fixed that up with some liquid tape before rewrapping so that was worth it. What I did find is a brown wire on the camera harness that is blunt cut and heat shrinked. It was right were the wire clamps to the underside of the bed. I tested it though and seems to not ohm to ground in any gear or have voltage in any gear. Anyone know what this wire is for.
69076
 

·
Premium Member
2021 General XP 4
Joined
·
111 Posts
Just thought I would throw an update here for anyone following. I got my service manual with the wiring diagrams. I'm not exactly positive what the point of this brown wire is. It seems to be related to video signal and is spliced right at the video connector to one of the camera pins.

More importantly the normal positive wire that should be there is spliced off of what it calls EFI+ so I think that shouldn't matter what 12V + source is used the way I read the diagram and after reading posts on wiring up the relay. The more important one is Beeper- and is supposed to go to position 45 on the Code 13 ECU connector. So easy enough to pull the ECU connector loose and take the jacket off and found out the problem there is no wire in that position and has a dummy terminal. So not sure if the ECU is still programmed to send out signal on that terminal 45 but hoping it is for ECU programming forward compatibility. The terminal is only 1.30 the shipping is a bit worse but I ordered it and will see what the multimeter says when I get it installed.
69313
 

·
Registered
Joined
·
283 Posts
Keep us updated on what you find out. Thanks for checking into it.
 
  • Like
Reactions: kc81c

·
Premium Member
2021 General XP 4
Joined
·
111 Posts
Thats a good video Talon but unfortunately thoose of us with 21 XP4s have an extra step being we are missing the needed wires. The good news though is SUCCESS. I received my pins in the mail today and got some time this evening to put the backup lights in and do a write up on it. I put the write up in another thread just to keep it cleaner.

69416
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #36 ·
Sorry I have been remiss about being in touch. It’s cowboy shooting season and I’m gone to 2-3 shoots a month.

Just to wrap it up for me...as I mentioned, I installed the B/U lights and wired them to a rocker. I also added: horn, L/R mirrors, front light bar, roof liner, vented windshield. I have the wiring harness from Corbin’s for the turn signals and I want to add sturdier skid plates, so I still have things to do.

I was able to do much of the above thanks to the great folks here who share their knowledge and experience.

I also now believe I will never truly be through with things to add or improve on the General so look for me pestering y’all!
 

·
Registered
2020 General 1000
Joined
·
7 Posts
Just thought I would throw an update here for anyone following. I got my service manual with the wiring diagrams. <clip>

More importantly the normal positive wire that should be there is spliced off of what it calls EFI+ so I think that shouldn't matter what 12V + source is used the way I read the diagram and after reading posts on wiring up the relay. The more important one is Beeper- and is supposed to go to position 45 on the Code 13 ECU connector. So easy enough to pull the ECU connector loose and take the jacket off and found out the problem there is no wire in that position and has a dummy terminal. So not sure if the ECU is still programmed to send out signal on that terminal 45 but hoping it is for ECU programming forward compatibility. The terminal is only 1.30 the shipping is a bit worse but I ordered it and will see what the multimeter says when I get it installed.
Thanks, great info! I just installed bed/work lights on my General and was wondering the same that one should be able to find the correct pin from the ECU to supply 12V while on reverse gear even if the connectors are missing from the chassis harness (like they do on the EU versions...). I got the workshop manual from Gilomen, but as it is missing the wiring schematics, I would like to ask if you could share the schematics you have?
 

·
Premium Member
2021 General XP 4
Joined
·
111 Posts
Thanks, great info! I just installed bed/work lights on my General and was wondering the same that one should be able to find the correct pin from the ECU to supply 12V while on reverse gear even if the connectors are missing from the chassis harness (like they do on the EU versions...). I got the workshop manual from Gilomen, but as it is missing the wiring schematics, I would like to ask if you could share the schematics you have?
I have it all working along with a few other members. I thought I had left a link to it above but I must have forgot it. Success Installing backup lights on a 21 General XP 4 or any general that doesn't have the beeper wires in the harness. | Polaris General Forum
 

·
Registered
2020 General 1000
Joined
·
7 Posts

·
Premium Member
2021 General XP 4
Joined
·
111 Posts
I don't have an easy way to scan in the wiring diagrams because they are such large sheets and glued into the book. Also there is different diagrams for different models. If there is something specific you are looking for though what I have done is taken pictures of that part of the diagram in the past.
 
21 - 40 of 41 Posts
Top