Polaris General Forum banner
21 - 40 of 52 Posts

·
Premium Member
2016 Polaris General Deluxe, 10% OEM
Joined
·
4,875 Posts
OK, got the fuel pump test kit modified to work on a General. Took a video of the test sequence from start to finish. Yes, lifters rattled but good. But changed the oil on return from trip in September and hasn't been started since. So it took a bit to get everything lubed again!

YouTube

Guess the fuel pump isn't the cause of my General being cold blooded on Fall mornings...
Pirate
 

·
Registered
Joined
·
1 Posts
I had same problem 2011 Ranger 800 Crew. Engine turns over fast like no compression or no plugs. Thought starter wasn't engaging but then it backfired so I realized motor was actually turning over. Got lucky and got an error code. Idle Air Control failure. Lifted seat and immediately saw that the seat had rubbed the wiring bare for the Idle Air Control Unit. Put silicone all over wires and I didn't have the problem again for 3 months until now 15 below Celcius. Ordered the wiring pigtail on ebay for the Idle Air Control Unit to see if that fixes it. If it was a carb on the motor I would say it is acting like no choke.
 

·
Registered
Joined
·
190 Posts
Last time I tried to start mine it was cold- about 20 degrees. I held the accelerator to the floor and cranked it. In a couple seconds it backfired then started. I tried this several more times and each time it seemed to start better by holding the gas to the floor
 

·
Registered
Joined
·
295 Posts
This is strange and shouldn't happen with fuel injection, computer and air monitoring of modern systems, Polaris must be dropping the ball here somewhere. I haven't tried starting mine in a few weeks, it's going to be below zero here, I'm going to go give it a try. Has anyone heard of this happening with the 2020 or 2019 models. To bad you can't re-flash your ECM or what-ever Polaris calls it, the computer basically.
 

·
Registered
2019 Polaris General Premium
Joined
·
204 Posts
Mine is a 2019 and I have had zero issues cold weather starting, its been real cold here this last week and I have started it up just fine, couple cranks and fires never sputters. Was -18 C in the garage last time a fired it up (-34C outside).
 

·
Registered
2020 General 4 1000, SuperATV 3” lift, Quad Boss 2” wheel spacers, Hunterworks rollers and belt
Joined
·
730 Posts
I have a 2020 sport (non XP). It’s starts great every time here in Missouri. But, while in Colorado last August I had this problem several mornings. Didn’t want to start instantly and had to crank several times to get started. I assume it’s altitude. I was also running 93 octane. Cold weather doesn’t seem to affect it unless it’s cold weather and altitude. It was cold mornings also in CO but here in missouri it’s in the 20’s right now and it starts fine.
 

·
Registered
Joined
·
993 Posts
Going to try what someone else posted. Add StaBil to the fuel and see if that helps.

Pirate
Pirate if your looking for something for long term storage then StaBil is a good product just don’t move the machine around once you add it or the Stabilization properties are compromised, if your looking for a all around additive to stabilize clean your fuel system and can run it all the time go with Seafoam it is a product you can run all year long that way it’s always in there.
 

·
Registered
Joined
·
190 Posts
I run Archoil in all of my gas powered engines. Had no effect on how the General starts. What it does do is clean out clogged up carbs. My Honda EU3000 would only run with the choke out. I ran a 3x normal dose of Archoil and it cleaned the carb out. Also worked on the carb on my Miller Bobcat.
I always put a double dose in all of my fuel but this doesn't prevent the ethanol problem. Now I have found a local source of ethanol free fuel and I run that in everything except my XP Turbo which needs high octane.
 

·
Registered
Joined
·
319 Posts
Yeah, get out there and start those Generals! It was -42F in Bemidji Mn this morning, but a balmy -24 just 35 miles to the south at our cabin. If I was there I would have tried to start it. I think it would have fired up in 3-4 seconds.

Reminds me when I was in college in Duluth in ‘96 (getting old I guess). It was -54F that morning. For giggles I went out to try and start my old Honda Civic hatchback. I turned the key and absolutely nothing happened. Shrugged shoulders and went back inside. Glad I don’t live in the colder parts of Alaska or Canada as that was crazy dang cold!
 

·
Registered
Joined
·
5,632 Posts
We don't miss that northern cold one bit, since moving south!
 
  • Like
Reactions: GeneralHendy

·
Registered
Joined
·
125 Posts
My 2017 Polaris General Hunter Edition 1000 EPS has the same problem. I live in east Texas and usually takes two engagements to get her started at home. When hunting in Utah or Idaho at altitudes between 4,000 to 10,000 feet it takes 3 sometimes 5 engagements to get it started. Brand new battery --- all connections tight. A new air filter. Running fresh 87 to 91 Octane non-ethanol gas with Sea-Foam. Doesn't matter if the temp is 40 degrees or minus 2; I know it will take 4 or 5 engagements to get her started. After that, no problem until the next morning. I'm so new at Polaris ownership, my gut tells me its related to altitude and/or cold weather.
I have a 2019 G-2 Ride Command. Last fall I was in the Truckee California area. Mornings were well below freezing. Both mornings I had a hard time starting my General. It would start but acted like not much fuel getting to the engine. I think it died a couple of times, tried pumping the gas pedal and after it finally started and ran normally, it was fine. Not a battery issue. I may try the warm up the relays method. I only use premium fuel, and add 1 oz of Stabil per 2.5 gallons. I use their Stabil Marine product add it as soon as I get home with the fuel or add to tank at the gas station. With the Ethanol fuel we have it starts going bad as soon as it arrives at the gas station and really gets bad within two weeks. So you need to use Ethanol Free or add stabilizer to the fuel. I have had issues lately with many friends and relatives with fouled carbs in Honda Generators and other equipment. Even with Ethanol laced fuel and Stabil in my fuel, I found a coating of the brown crap Ethanol coating my carburetor bowl on my two Honda 2200 Generators. I also removed a lot of crap plugging up the jets in other Honda Generators, Compressors, Power Washers, Lawn Mowers, etc. I have become an expert on removing and rehabbing carburetors.
 

·
Premium Member
2016 Polaris General Deluxe, 10% OEM
Joined
·
4,875 Posts
One thing I was told when my General didn't want to start in cooler weather...November 2019 in Moab. Was to look for "Winterized" gas. Found it at the Shell station on the South end of Moab.
Not a problems with first start in the morning after changing fuel.
I now follow the Polaris recommendation and use 87 octane fuel. Where I live in Southern Colorado there isn't a drop of Ethanol Free gasoline to be found. And given the world situation and what Big
Oil is going to do to America...there probably won't be a drop to be had.
Pirate
 

·
Registered
Joined
·
1,451 Posts
My rig runs just fine on this Mexican gas imported from Long Beach Cal-law-form-a.
I had starting issues about three years ago and turned out to be the Polaris fuel pump. I replaced it with a Quantum fuel pump and I’ve not had an issue starting the rig since.

I run Sea Foam as well, seems to keep things running good.

Cheers Baja Charlie
 

·
Registered
Joined
·
430 Posts
My '22 did this last weekend. Temps in the 40's at about 9,000ft elevation. After two cranking cycles with no start I was getting worried. On the third attempt I gave it fuel until it started.

Ran fine once started. Hope this isn't an all the time thing. I bought this machine to guide hunters this fall in the mountains of Wyoming. It is going to get much colder than last weekend and I need it to be reliable.

Maybe they have a block heater that can be put on this thing? Might work where I have access to power but I'd still be screwed in general.


Sent from my SM-N976U using Tapatalk
 
21 - 40 of 52 Posts
Top