Polaris General Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter #1
I have what I believe to be a cam chain in tensioner issue. 5400 miles on my 2016. Have had a ticking noise on cold start up for quite some time but is definitely getting worse recently, the noise only last for 10 seconds or so then goes away. Anyone else have this problem and replace the tensioner? What did you use?
 

·
Registered
Joined
·
129 Posts
How often are you changing oil. ?My dads rzr does it if he goes over 50hrs. All of our machines run 5w40 RotellaT full synthetic diesel oil. If we used polaris oil it would rattle at startup by 20ish hrs on the oil change
 

·
Registered
Joined
·
201 Posts
Discussion Starter #3
It’s been maintained per manual since new. It seems to be getting progressively worse the more miles I get on it.
 

·
Super Moderator
Joined
·
2,918 Posts
The '16s have a different tensioner than the following years, and was something I looked into early on, when I started getting noise on cold starts. Ours has a spring in it, but seems to be kind of weak, which I believe is why they changed it. I should also say, that you can not install a newer style tensioner on a 2016 model, as the even changed how it bolts to the engine. There are aftermarket options, though. You have 5400 miles, it may be wore out.

With that said, what I found to be the major contributer to my noise, was the oil filter. My dealer doesn't sell Polaris oil filters, they use K&N. The problem with that is, K&N filters don't have an anti-drain valve, so all the oil runs out of it, so on cold starts it is dry, takes longer to get oil to the chain, causing that rattling. After some reading on the RZR forum, I found that a NAPA Gold 1356 filter has the anti-drain, and almost completely done away with my rattling cold starts. Still get it on occasion, if it sets for a very long time, but not often.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #5
Thanks MMX! I am also running that filter as I’ve had the rattle from early on. Definitely seems to be getting worse as time goes on and I’ve read online they can jump time, I don’t need that so I am installing the Alba racing tensioner tomorrow.
 
1 - 7 of 7 Posts
Top