Polaris General Forum banner

41 - 60 of 68 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #41
So I got a little time to install my tip out front glass. Well let me re phrase that, attempted to install. I’ve installed 4 of these windshield and I’ve never had a problem like I’m having with this one. Got it all set up, go to tighten the brackets and the window moves a 1/2 inch towards the drivers side. Loose it up and re adjust and it does it again. I go ahead and swap the brackets and it pulls
It to the passenger side. I’ve men fighting this bugger for an hour and a half and I’m getting mad. I called the dealer and they said, well the tolerance of the roll cage is anywhere from 3/4 to 1 inch in either direction. It could be the cage or it could be the brackets on the windshield. Then they proceeded to tell me to bring it in and they will look at it. But they want to charge me 110 bucks to “install” the windshield when I just dropped 27 grand with them. I don’t know when I’m goin to be able to get to to the dealer for them to take a look at it, I work nights and by the time they open I’m supposed to be asleep. It’s a 40ish mile drive one way so might have to be in a week when I have a day off.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
107 Posts
So I got a little time to install my tip out front glass. Well let me re phrase that, attempted to install. I’ve installed 4 of these windshield and I’ve never had a problem like I’m having with this one. Got it all set up, go to tighten the brackets and the window moves a 1/2 inch towards the drivers side. Loose it up and re adjust and it does it again. I go ahead and swap the brackets and it pulls
It to the passenger side. I’ve men fighting this bugger for an hour and a half and I’m getting mad. I called the dealer and they said, well the tolerance of the roll cage is anywhere from 3/4 to 1 inch in either direction. It could be the cage or it could be the brackets on the windshield. Then they proceeded to tell me to bring it in and they will look at it. But they want to charge me 110 bucks to “install” the windshield when I just dropped 27 grand with them. I don’t know when I’m goin to be able to get to to the dealer for them to take a look at it, I work nights and by the time they open I’m supposed to be asleep. It’s a 40ish mile drive one way so might have to be in a week when I have a day off.


Sent from my iPhone using Tapatalk
That's not good I ordered a tip out...waiting to hear the solution

Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
78 Posts
That’s not good hate to hear that. My dealer offered to install of my stuff when it comes in the way that sounds it might be worth it. I usually put accessories on myself but hearing that probably will let them do it that way if they screw something up it’s not on me.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #45
That’s not good hate to hear that. My dealer offered to install of my stuff when it comes in the way that sounds it might be worth it. I usually put accessories on myself but hearing that probably will let them do it that way if they screw something up it’s not on me.
The dealer where will bought my general from said they haven’t seen this before lol just my luck. So it will be going back Tuesday morning. They are going to have someone there a little early for me so I can drop it off after work. I will be talking to the service manager and make a Stink if I have to about the 110 bucks for install after a 27k investment with them.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
78 Posts
I would be too. Good luck hope they can get the problem resolved.
 

·
Registered
Joined
·
107 Posts
Shady ass factory workers....
They blow out the screw hole so a zip tie will fix it


Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
27 Posts
I would take it to the dealer and make sure everything gets taken care of... not “fixed” but replaced. That’s total BS.
mid this is what you can see... possibility of something you can’t see being handled like that, I wouldn’t accept it.
 

·
Registered
Joined
·
36 Posts
Shady ass factory workers....
They blow out the screw hole so a zip tie will fix it


Sent from my Moto Z (2) using Tapatalk
Where is that at on your General, I am hoping to take delivery soon, apparently I will be going over the whole machine with them and a fine tooth comb....
 

·
Registered
Joined
·
107 Posts
Biggest problem is I didn't notice it till I went to put it it back together after wiring the reverse lights


Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
169 Posts
Discussion Starter #53
Biggest problem is I didn't notice it till I went to put it it back together after wiring the reverse lights


Sent from my Moto Z (2) using Tapatalk
Hey when your machine is running and you hit the winch in it out does your whole dash dim really bad? Mine is doing it and don’t know why. Just dropped it back off at the dealer to get some things looked at.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
107 Posts
Haven't had to use it yet but as loose as my main ground was I could see that being the issue

Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
169 Posts
Discussion Starter #55
Haven't had to use it yet but as loose as my main ground was I could see that being the issue

Sent from my Moto Z (2) using Tapatalk
Oh ok. My machine is at the dealer as of this morning for a few things they are gonna fix. The winch was one of them so I’ll check the ground if they don’t figure it out. I hope they do figure it out. I’m gonna be laid up for a few weeks, found out that I tore my meniscus on my knee and will more likely be having surgery so not gonna be too mobile to get my projects done


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
169 Posts
Discussion Starter #56
Haven't had to use it yet but as loose as my main ground was I could see that being the issue

Sent from my Moto Z (2) using Tapatalk
So my dealer called me about my general winch problems and the ride command. As for the ride command fader not working they just basically said though **** it’s the way it’s designed. As for the winch they takes to a polaris engineer and they said it’s the way the machine is designed. The winch is hooked to the buss bar and nothing they can do about it. But it is documented so if something goes wrong it can be addressed. I told them I have a 4 year warranty so I’d doesn’t matter if it’s documented or not. Something goes wrong it’s gonna be fixed regardless. I don’t see why they can’t just fix the dam problems instead of making excuses. Almost 30k on this thing and they just brush it off. I feel like I should of kept my old General, I had all the bugs worked out of it already.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
78 Posts
It’s sad to say but that’s pretty much the world we live in now nobody wants to take any responsibility pass it off and hope you go away.
 

·
Registered
Joined
·
2,660 Posts
They either say they never heard of this problem before or they say that is just the way it is!
Really? What a bunch of BS.
Nowadays they just build them quickly and get them out the door and let someone else worry about it if not put together right. They need to overhaul their Quality Control and do it quickly.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #59
So I picked up my general from the dealer for the above mentioned warranty work, asked the service advisor about the winch again. He said that polaris offers a harness that directly connects the winch to the battery and not the bus bar and it it polaris recommendation on how to fix it. He said it’s an accessory that I would have to pay for. I told him I’m not paying for crap. I just spent a lot of money on this thing and it’s doing this right from delivery. He proceeds to tell me, well I can open an case with Polaris and see if they will offer the fix. I told him isn’t that why you did since it was “documented” and now traceable for future reference. He didn’t have a lot to say after that. Either he is full of it or he is just that stupid. I guess I’m gonna call polaris my self and start making a stink. I mean might as well, I’ll bring up the ride command also and see if I can get anywhere.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
78 Posts
Go for it you have nothing to lose.
 
41 - 60 of 68 Posts
Top