Polaris General Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Hi All,

Love this machine, except the stereo.

Our old stage 1 Rockford setup in the old General was MUCH louder than this one.

With this setup and the volume set to max you can barely hear the music over the engine. And, naturally, it's a little distorted. Doesn't matter if we are listening to the FM radio, bluetooth or a USB stick with tunes on it.

Anyone else seeing this or is something wrong with mine?

With the engine off or slow cruising it sounds nice, tones are good. But when you want to listen while riding it's nearly useless. Wasn't worth giving up the factory heater for it.

laters,
marlon
 

·
Registered
Joined
·
26 Posts
I am with you on how low the volume is but have no reference as to how loud the other Rockford fosgate system is since this is my first sxs. What I do know is my stage 2 subwoofer isn’t working. I pulled the dash pad and disconnected it and it made no difference. Very disappointed.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
43 Posts
I am with you on how low the volume is but have no reference as to how loud the other Rockford fosgate system is since this is my first sxs. What I do know is my stage 2 subwoofer isn’t working. I pulled the dash pad and disconnected it and it made no difference. Very disappointed.


Sent from my iPhone using Tapatalk
I have the rockford stage 3 kit and 3/4 volume is plenty. Maybe at 70 with a helmet on you'd want full volume. It would still be loud in those circumstances though. It is awesome. Now I also don't hear a lot of base coming from my rockford head unit. I have a sub + and sub - button. I hear no difference between sub +20 and +0. I am going to call rockford and ask probably. The sub is moving when music is playing it just doesn't seem to be doing much.
 

·
Registered
Joined
·
1 Posts
I'm not impressed with the volume of the stereo either,
One question I have is I was playing music from my IPhone via Bluetooth and it kept repeating the same song over & over so i would have to hit Forward after each song was done playing, has anyone else had this problem
 

·
Registered
Joined
·
36 Posts

have you tried this?
 

·
Registered
Joined
·
2,470 Posts
A person on another thread said he did a Ride Command update and it fixed his. Here is the link about what he said.

 

·
Registered
Joined
·
2,470 Posts
If you do an update then come back and let us know if it helped or not.
 

·
Registered
Joined
·
60 Posts
Change your region from North America to Europe. It should drastically increase the volume output of your system. You can then change it back to North America. You need to do this every time you turn the machine on. A little frustrating but it works. Polaris is aware of the issue and working on a software fix.
 

·
Registered
Joined
·
84 Posts
Discussion Starter #10
So I tried this. It does work, and work well. The RADIO is much louder at much lower settings. Very much like I would expect it to be.

However, that setting does absolutely nothing for any connection other than the radio. Bluetooth and USB stick are still all but useless at speed.

laters,
marlon
 

·
Registered
Joined
·
7 Posts
Just got my 2020 XP4 Deluxe w/ Ride Command and very disappointed in the stereo. Have to be near max volume to hear it on Bluetooth when riding. I’ve read all the threads on it and have updated the ride command and changed the region to no avail. I didn’t check it on FM because reception is mostly garbage near me and I just never listen to regular radio.

The good news is, this is the one upgrade my wife is actually pushing me to do. She doesn’t care about the light bars, mirrors, rock sliders and all the fun stuff, but the stereo needs to sound better or she won’t be happy.

Has anybody done anything like upgrading amp or anything? It feels underpowered and just seems like it needs more amp. I’m no stereo guy so don’t know for sure. Just wondering if anyone has done anything other than messing with settings
 

·
Registered
Joined
·
24 Posts
Rockford Fosgate customer service rep told me that I would need this amp (Power Marine 1,000 Watt Class-ad 5-Channel Amplifier | Rockford Fosgate ®) to be able to actually use the fade function of the system. This is due to Polaris only including a 2 channel amp with the system. I will be replacing the amp at some pont in the future with is. I assume it will be much louder due to the increase wattage.
Did they say if it is similar in size? Will it fit in current location or will mods have to be made?
 

·
Registered
Joined
·
7 Posts
Rockford Fosgate customer service rep told me that I would need this amp (Power Marine 1,000 Watt Class-ad 5-Channel Amplifier | Rockford Fosgate ®) to be able to actually use the fade function of the system. This is due to Polaris only including a 2 channel amp with the system. I will be replacing the amp at some pont in the future with is. I assume it will be much louder due to the increase wattage.
Thanks, has anyone looked at the speakers/sub to see what model(s) they are? I'm sure they'll carry 100w of power each, but just want to know if that is the next domino to fall and speakers need upgraded too. If they went cheap on the amp, they probably bought the lowest end speaker in the lineup as well.
 

·
Registered
Joined
·
35 Posts
This is so wrong. Both Rockford Fostgate and Polaris are to blame. Deceptive advertising. We shouldn't have to purchase anything new. What was Rockford Fostgate thinking when they allowed Polaris to wire a 2 channel amp into a stereo that needs a 5 channel amp with the Rockford Fostgate name on it. Unbeleivable! I wonder if a class-action lawsuit is possible. If I have to buy another marine grade amp it won't be a Rockford Fostgate. Overrated garbage!
 

·
Registered
Joined
·
7 Posts
So I had my stereo guy out and he definitely said the amp is a problem. He recommended a 5-6 channel amp like 1Truckey said. He did say it will likely need a ride command harness to the amp as he didn't know if the existing one would work for a larger amp or not and said it might need re-wired to the battery. We're going to start with the amp and see how it sounds and we'll find out if the rest of the components are junk or not. He said the speakers don't look bad, but we won't know until we put more power to them. I'll keep you all posted as to where we end up.
 

·
Registered
Joined
·
35 Posts
Thanks for the info. If you do go ahead with replacing components can you post links to what you replaced. I might go the route you’re going.
 

·
Registered
Joined
·
6 Posts
This is so wrong. Both Rockford Fostgate and Polaris are to blame. Deceptive advertising. We shouldn't have to purchase anything new. What was Rockford Fostgate thinking when they allowed Polaris to wire a 2 channel amp into a stereo that needs a 5 channel amp with the Rockford Fostgate name on it. Unbeleivable! I wonder if a class-action lawsuit is possible. If I have to buy another marine grade amp it won't be a Rockford Fostgate. Overrated garbage!
I agree with you. Polaris should be fixing this for us. How can you charge so much for a system that isn't even properly configured. Its like selling consumers a brand new car with an engine not capable of going the speed limit haha. The subwoofer is basically not doing anything, all because it isn't getting fed right. Rockford Fosgate speakers aren't bad at all, this system should pound with the right amp. From my understanding the Ride Command machines have a different amp then the machines with the standard head unit. I hear that the stage 4 with the standard head unit sounds really good but maybe I am wrong on that. Maybe it is difficult to get the system to work properly with the RC but it is unacceptable to release it this way. Fix it before you sell it to people. Polaris owes us a proper amp. I think its important for all of us to put in complaints about it, try to force them into doing something about it.
 
1 - 20 of 20 Posts
Top